Pages

Monday, 9 April 2012

INST-07248: Specified OEPE home location is not a valid location Enter a valid OEPE home location

I was trying to install Oracle service bus (osb) on my existing SOA installation and got below error in the setup wizard while providing the eclipse (OEPE) location :

INST-07248: Specified OEPE home location is not a valid location Enter a valid OEPE home location


Cause:

A perticular version of your OSB needs a specific OEPE version for adding osb releted eclipse plugins.
In my case my osb version is 11.1.1.4 for which the corresponding OEPE version is 11.1.1.6.1 . If you have some other oepe version, you will get above error.

Fix:

First find out which version of OEPE is required for your osb version get that installed (its really need unzipping the downloaded zip in your middleware home). You can get oepe  download for various version at below url:
http://www.oracle.com/technetwork/developer-tools/eclipse/downloads/index.html

Then you provide that location and it should work this time.
If you are not sure about the eclipse verion, then while installing weblogic server, select the server setup with OEPE . That way you will get the correct OEPE installed.

Hope this will help fix your issue. If not, feel free to comment about it and I will try to help you out.

5 comments:

  1. Is it possible to install OSB 11.1.1.5 without the OEPE package (it is in WLS10.3.6)? Since I am running OSB in a productive setup I don't need OEPE.

    Thx
    Stephan

    ReplyDelete
    Replies
    1. Yes , it is possible.
      In the instillation wizard, you should select custom installation and then unselected OEPE.

      Delete
  2. I am using oepe-wls-indigo-installer-11.1.1.8.0.201110211138-10.3.6-win32.exe after which i tried to install ofm_osb_generic_11.1.1.6.0_disk1_1of1.zip. I believe these are compatible versions inspite of that i am getting the error INST-07248: Specified OEPE home location is not a valid location Enter a valid OEPE home location.

    ReplyDelete
  3. Same problem here. Same versions. These still are the most recent. Any solutions? Anyone installed these versions succesfully?

    ReplyDelete
  4. Problem solved. I updated OEPE before installing osb. A clean install of OEPE solved the problem.

    ReplyDelete